返信先: Qapacheを使ってのPHP7のインストール

#965
ymitsuru57ymitsuru57
参加者

    Adminさん、

    コメントありがとうございます。

    現在TS-253Bを使っています。これまでTS-119IIでJoomlaを稼動させていましたが、phpMyAdminも古いまま(ARM系は4.0.10.20、Intel系は4.7.4.0となっている)なのでIntel系へ移行を決めました。(現在HS-251も所有しているんですが、メモリー的に非力なので253Bにしました。)

    Qapacheはqpkgがあったので(ご指摘のとおりApache 2.4.29 + PHP 7.1.11 + PECL Extensionを使いました。)インストールは簡単に出来ました。しかしどうもこのApacheはDataVol1/Web上ではなく、/htdocs上で動作しているようです。

    私自身ApacheやPHPに対する経験・知識が乏しいため、Joomlaのインストールの際やトラブルの時にphpMyAdminを使ってデータベースの操作をする程度です。

    今直面している問題はApache 2.4.29 + PHP 7.1.11でphpMyAdminが(/htdocs上に)インストールできるのか?出来ない場合PHP7のconnectionにおけるユーザ管理(rootのパスワードなど)をどうしたらよいのか分かっていなくて苦労しています。

    また優先度は低いのですが、Apache 2.4.29 + PHP 7.1.11のdefaultのWeb portは88になっており、80とした場合QNAPのWebサーバーの処理とぶつからないかと心配しています。(この辺りが自己責任なんでしょうが)

    最後にDockerですが、Containerを起動すれば同様の機能が使える気がするのですが、これについてもこれから勉強しなければならない段階です。